aboutsummaryrefslogtreecommitdiffhomepage
path: root/cuda_base/Cargo.toml
diff options
context:
space:
mode:
authorAndrzej Janik <[email protected]>2024-11-14 16:52:58 +0000
committerAndrzej Janik <[email protected]>2024-11-14 16:52:58 +0000
commitaaf8356a545d284b43d2e89d9d08e1c8c53ad00e (patch)
treeae5f7c003b0229fcbe3f0049ffd468ba5eb0370a /cuda_base/Cargo.toml
parent13c6d3dd94161be8e6387e3c0230637db4e9a50d (diff)
downloadZLUDA-aaf8356a545d284b43d2e89d9d08e1c8c53ad00e.tar.gz
ZLUDA-aaf8356a545d284b43d2e89d9d08e1c8c53ad00e.zip
Redefine Curesult as Result<...>
Diffstat (limited to 'cuda_base/Cargo.toml')
-rw-r--r--cuda_base/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/cuda_base/Cargo.toml b/cuda_base/Cargo.toml
index 997a426..9c9d531 100644
--- a/cuda_base/Cargo.toml
+++ b/cuda_base/Cargo.toml
@@ -2,11 +2,11 @@
name = "cuda_base"
version = "0.0.0"
authors = ["Andrzej Janik <[email protected]>"]
-edition = "2018"
+edition = "2021"
[dependencies]
quote = "1.0"
-syn = { version = "1.0", features = ["full", "visit-mut"] }
+syn = { version = "2.0", features = ["full", "visit-mut"] }
proc-macro2 = "1.0"
rustc-hash = "1.1.0"