aboutsummaryrefslogtreecommitdiffhomepage
path: root/xtask/Cargo.toml
diff options
context:
space:
mode:
authorAndrzej Janik <[email protected]>2021-02-27 20:55:19 +0100
committerAndrzej Janik <[email protected]>2024-02-11 20:45:51 +0100
commit1b9ba2b2333746c5e2b05a2bf24fa6ec3828dcdf (patch)
tree0b77ca4a41d4f232bd181e2bddc886475c608784 /xtask/Cargo.toml
parent60d2124a16a7a2a1a6be3707247afe82892a4163 (diff)
downloadZLUDA-1b9ba2b2333746c5e2b05a2bf24fa6ec3828dcdf.tar.gz
ZLUDA-1b9ba2b2333746c5e2b05a2bf24fa6ec3828dcdf.zip
Nobody expects the Red Teamv3
Too many changes to list, but broadly: * Remove Intel GPU support from the compiler * Add AMD GPU support to the compiler * Remove Intel GPU host code * Add AMD GPU host code * More device instructions. From 40 to 68 * More host functions. From 48 to 184 * Add proof of concept implementation of OptiX framework * Add minimal support of cuDNN, cuBLAS, cuSPARSE, cuFFT, NCCL, NVML * Improve ZLUDA launcher for Windows
Diffstat (limited to 'xtask/Cargo.toml')
-rw-r--r--xtask/Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/xtask/Cargo.toml b/xtask/Cargo.toml
new file mode 100644
index 0000000..2a214e4
--- /dev/null
+++ b/xtask/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+name = "xtask"
+version = "0.0.0"
+authors = ["Andrzej Janik <[email protected]>"]
+edition = "2018"
+
+[dependencies]
+argh = "0.1"
+# v18 requires rust 1.70 or higher
+cargo_metadata = "=0.17.0"
+# cargo-platform is a cargo_metadata, version 0.1.6 requires rust 1.70 or higher
+cargo-platform = "=0.1.5"
+serde = "1.0.193"
+serde_json = "1.0.108" \ No newline at end of file