aboutsummaryrefslogtreecommitdiffhomepage
path: root/zluda_lib/Cargo.toml
diff options
context:
space:
mode:
authorAndrzej Janik <[email protected]>2021-01-08 17:17:46 +0100
committerGitHub <[email protected]>2021-01-08 17:17:46 +0100
commit078ae20c2c0aff93858eeb69d0c46dad4d997998 (patch)
tree38d2313c5bab64e2a84c90a219bd60ce6808f116 /zluda_lib/Cargo.toml
parent2c0e9b912fe341bd1e513614014fa43b666d257d (diff)
downloadZLUDA-078ae20c2c0aff93858eeb69d0c46dad4d997998.tar.gz
ZLUDA-078ae20c2c0aff93858eeb69d0c46dad4d997998.zip
Improve build procedure and instructions (#28)
Fixes issues pointed out in #27: * spirv_tools-sys was build in non-test profiles * By default ZLUDA dll has a wrong name * We relied on third-party OpenCL installation on Windows * We encouraged building debug configuration * We didn't provide build information for developers (cmake, python, submodules)
Diffstat (limited to 'zluda_lib/Cargo.toml')
-rw-r--r--zluda_lib/Cargo.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/zluda_lib/Cargo.toml b/zluda_lib/Cargo.toml
new file mode 100644
index 0000000..54a2d53
--- /dev/null
+++ b/zluda_lib/Cargo.toml
@@ -0,0 +1,12 @@
+[package]
+name = "zluda_lib"
+version = "0.0.0"
+authors = ["Andrzej Janik <[email protected]>"]
+edition = "2018"
+
+[lib]
+name = "nvcuda"
+crate-type = ["cdylib"]
+
+[dependencies]
+zluda = { path = "../zluda" }