aboutsummaryrefslogtreecommitdiffhomepage
path: root/detours-sys/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'detours-sys/Cargo.toml')
-rw-r--r--detours-sys/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/detours-sys/Cargo.toml b/detours-sys/Cargo.toml
new file mode 100644
index 0000000..9ba0a3f
--- /dev/null
+++ b/detours-sys/Cargo.toml
@@ -0,0 +1,39 @@
+[package]
+name = "detours-sys"
+version = "0.1.2"
+authors = ["Diana <[email protected]>"]
+edition = "2018"
+links = "detours"
+# Package stuff
+description = "Rust bindings to Microsoft Detours"
+documentation = "https://github.com/microsoft/Detours/wiki/Reference"
+homepage = "https://github.com/DianaNites/detours"
+repository = "https://github.com/DianaNites/detours"
+readme = "README.md"
+keywords = [
+ "detours",
+ "hooking",
+ "injection",
+]
+categories = [
+ "external-ffi-bindings",
+ "os::windows-apis",
+]
+license = "MIT OR Apache-2.0"
+exclude = [
+ "/.vscode/**"
+]
+
+[badges]
+maintenance = { status = "as-is" }
+
+[dev-dependencies.winapi]
+version = "0.3"
+features = [
+ "synchapi",
+ "processthreadsapi",
+ "sysinfoapi",
+]
+
+[build-dependencies]
+cc = "1.0"