aboutsummaryrefslogtreecommitdiffhomepage
path: root/ptx/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ptx/Cargo.toml')
-rw-r--r--ptx/Cargo.toml8
1 files changed, 5 insertions, 3 deletions
diff --git a/ptx/Cargo.toml b/ptx/Cargo.toml
index d485286..2e2995f 100644
--- a/ptx/Cargo.toml
+++ b/ptx/Cargo.toml
@@ -2,12 +2,13 @@
name = "ptx"
version = "0.0.0"
authors = ["Andrzej Janik <[email protected]>"]
-edition = "2018"
+edition = "2021"
[lib]
[dependencies]
ptx_parser = { path = "../ptx_parser" }
+llvm_zluda = { path = "../llvm_zluda" }
regex = "1"
rspirv = "0.7"
spirv_headers = "1.5"
@@ -26,8 +27,9 @@ version = "0.19.12"
features = ["lexer"]
[dev-dependencies]
-hip_runtime-sys = { path = "../hip_runtime-sys" }
-tempfile = "3"
+hip_runtime-sys = { path = "../ext/hip_runtime-sys" }
+comgr = { path = "../comgr" }
spirv_tools-sys = { path = "../spirv_tools-sys" }
+tempfile = "3"
paste = "1.0"
cuda-driver-sys = "0.3.0"