aboutsummaryrefslogtreecommitdiffhomepage
path: root/zluda/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'zluda/Cargo.toml')
-rw-r--r--zluda/Cargo.toml17
1 files changed, 8 insertions, 9 deletions
diff --git a/zluda/Cargo.toml b/zluda/Cargo.toml
index 837b734..14e9845 100644
--- a/zluda/Cargo.toml
+++ b/zluda/Cargo.toml
@@ -2,26 +2,25 @@
name = "zluda"
version = "0.0.0"
authors = ["Andrzej Janik <[email protected]>"]
-edition = "2018"
+edition = "2021"
[lib]
-name = "zluda"
+name = "nvcuda"
+crate-type = ["cdylib"]
[dependencies]
+comgr = { path = "../comgr" }
+ptx_parser = { path = "../ptx_parser" }
ptx = { path = "../ptx" }
+cuda_types = { path = "../cuda_types" }
+cuda_base = { path = "../cuda_base" }
hip_runtime-sys = { path = "../ext/hip_runtime-sys" }
lazy_static = "1.4"
num_enum = "0.4"
lz4-sys = "1.9"
tempfile = "3"
paste = "1.0"
-
-[dependencies.ocl-core]
-version = "0.11"
-features = ["opencl_version_1_2", "opencl_version_2_0", "opencl_version_2_1"]
+rustc-hash = "1.1"
[target.'cfg(windows)'.dependencies]
winapi = { version = "0.3", features = ["heapapi", "std"] }
-
-[dev-dependencies]
-cuda-driver-sys = "0.3.0" \ No newline at end of file