aboutsummaryrefslogtreecommitdiffhomepage
path: root/zluda_dnn/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'zluda_dnn/Cargo.toml')
-rw-r--r--zluda_dnn/Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/zluda_dnn/Cargo.toml b/zluda_dnn/Cargo.toml
new file mode 100644
index 0000000..1ba5dce
--- /dev/null
+++ b/zluda_dnn/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "zluda_dnn"
+version = "0.0.0"
+authors = ["Andrzej Janik <[email protected]>"]
+edition = "2018"
+
+[lib]
+name = "cudnn"
+crate-type = ["cdylib"]
+
+[dependencies]
+miopen-sys = { path = "../miopen-sys" }
+hip_runtime-sys = { path = "../hip_runtime-sys" }
+
+[package.metadata.zluda]
+linux_only = true
+linux_names = ["libcudnn.so.7", "libcudnn.so.8"]
+dump_names = ["libcudnn.so"]