aboutsummaryrefslogtreecommitdiffhomepage
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Johanson <[email protected]>2024-03-25 09:37:14 +0000
committerPete Johanson <[email protected]>2024-03-27 20:59:26 -0700
commit41d81801ed11a1dca918c9c0088351856e4e1808 (patch)
tree6db4e8ae826ff71fe212613bd37b5b17be443d06 /app/CMakeLists.txt
parentd0e0ecb4e3d11b5303c1dc5c857ff1f75c1d0aaa (diff)
downloadzmk-41d81801ed11a1dca918c9c0088351856e4e1808.tar.gz
zmk-41d81801ed11a1dca918c9c0088351856e4e1808.zip
fix(pm): Use Zephyr created device slots.
* Avoid overwriting random memory by using iterable section created by Zephyr PM.
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index 2744f53d59..0b681ea953 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -8,10 +8,6 @@ set(ZEPHYR_EXTRA_MODULES "${ZMK_EXTRA_MODULES};${CMAKE_CURRENT_SOURCE_DIR}/modul
find_package(Zephyr REQUIRED HINTS ../zephyr)
project(zmk)
-if(CONFIG_ZMK_PM_DEVICE_SUSPEND_RESUME)
- zephyr_linker_sources(SECTIONS include/linker/zmk-pm-devices.ld)
-endif()
-
zephyr_linker_sources(SECTIONS include/linker/zmk-behaviors.ld)
zephyr_linker_sources(RODATA include/linker/zmk-events.ld)