aboutsummaryrefslogtreecommitdiffhomepage
path: root/app/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Rascher <[email protected]>2021-06-09 18:51:28 -0500
committerPete Johanson <[email protected]>2021-11-15 05:49:23 -0500
commite9140b2da914ee121e7f40eaeb8c6cf827d03622 (patch)
tree483b9f93035a4a7f393d753c63bd1c2b215598e1 /app/CMakeLists.txt
parentf8018b22d0bcba97e54652a01e8bdefb15f83c4c (diff)
downloadzmk-e9140b2da914ee121e7f40eaeb8c6cf827d03622.tar.gz
zmk-e9140b2da914ee121e7f40eaeb8c6cf827d03622.zip
feat(conditional-layers): Implement feature
This is a generalization of the existing concept of tri-layer support that's already well known. Essentially, a conditional-layer configuration activates a particular layer (the then-layer) when one or more other layers (the if-layers) are activated. This is commonly used on ortho keyboards to activate a third "adjust" layer while the primary two layers ("lower" and "raise") are active.
Diffstat (limited to 'app/CMakeLists.txt')
-rw-r--r--app/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/app/CMakeLists.txt b/app/CMakeLists.txt
index 5092deffe1..9c7befec77 100644
--- a/app/CMakeLists.txt
+++ b/app/CMakeLists.txt
@@ -57,6 +57,7 @@ if ((NOT CONFIG_ZMK_SPLIT) OR CONFIG_ZMK_SPLIT_BLE_ROLE_CENTRAL)
target_sources(app PRIVATE src/behaviors/behavior_sensor_rotate_key_press.c)
target_sources_ifdef(CONFIG_ZMK_EXT_POWER app PRIVATE src/behaviors/behavior_ext_power.c)
target_sources(app PRIVATE src/combo.c)
+ target_sources(app PRIVATE src/conditional_layer.c)
target_sources(app PRIVATE src/keymap.c)
endif()
target_sources_ifdef(CONFIG_ZMK_RGB_UNDERGLOW app PRIVATE src/behaviors/behavior_rgb_underglow.c)