aboutsummaryrefslogtreecommitdiffhomepage
path: root/Cargo.toml
diff options
context:
space:
mode:
authorYuchen Wu <[email protected]>2024-02-27 20:25:44 -0800
committerYuchen Wu <[email protected]>2024-02-27 20:25:44 -0800
commit8797329225018c4d0ab990166dd020338ae292dc (patch)
tree1e8d0bf6f3c27e987559f52319d91ff75e4da5cb /Cargo.toml
parent0bca116c1027a878469b72352e1e9e3916e85dde (diff)
downloadpingora-8797329225018c4d0ab990166dd020338ae292dc.tar.gz
pingora-8797329225018c4d0ab990166dd020338ae292dc.zip
Release Pingora version 0.1.0v0.1.0
Co-authored-by: Andrew Hauck <[email protected]> Co-authored-by: Edward Wang <[email protected]>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml35
1 files changed, 34 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d9e553f..1fb8c97 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,4 +1,37 @@
[workspace]
+resolver = "2"
members = [
+ "pingora",
+ "pingora-core",
+ "pingora-pool",
+ "pingora-error",
"pingora-limits",
-] \ No newline at end of file
+ "pingora-timeout",
+ "pingora-header-serde",
+ "pingora-proxy",
+ "pingora-cache",
+ "pingora-http",
+ "pingora-lru",
+ "pingora-openssl",
+ "pingora-boringssl",
+ "pingora-runtime",
+ "pingora-ketama",
+ "pingora-load-balancing",
+ "pingora-memory-cache",
+ "tinyufo",
+]
+
+[workspace.dependencies]
+tokio = "1"
+async-trait = "0.1.42"
+httparse = "1"
+bytes = "1.0"
+http = "1.0.0"
+log = "0.4"
+h2 = ">=0.4.2"
+once_cell = "1"
+lru = "0"
+ahash = ">=0.8.9"
+
+[profile.bench]
+debug = true