aboutsummaryrefslogtreecommitdiffhomepage
path: root/pingora-header-serde/Cargo.toml
diff options
context:
space:
mode:
authorYuchen Wu <[email protected]>2024-02-27 20:25:44 -0800
committerYuchen Wu <[email protected]>2024-02-27 20:25:44 -0800
commit8797329225018c4d0ab990166dd020338ae292dc (patch)
tree1e8d0bf6f3c27e987559f52319d91ff75e4da5cb /pingora-header-serde/Cargo.toml
parent0bca116c1027a878469b72352e1e9e3916e85dde (diff)
downloadpingora-8797329225018c4d0ab990166dd020338ae292dc.tar.gz
pingora-8797329225018c4d0ab990166dd020338ae292dc.zip
Release Pingora version 0.1.0v0.1.0
Co-authored-by: Andrew Hauck <[email protected]> Co-authored-by: Edward Wang <[email protected]>
Diffstat (limited to 'pingora-header-serde/Cargo.toml')
-rw-r--r--pingora-header-serde/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/pingora-header-serde/Cargo.toml b/pingora-header-serde/Cargo.toml
new file mode 100644
index 0000000..2968cae
--- /dev/null
+++ b/pingora-header-serde/Cargo.toml
@@ -0,0 +1,32 @@
+[package]
+name = "pingora-header-serde"
+version = "0.1.0"
+authors = ["Yuchen Wu <[email protected]>"]
+license = "Apache-2.0"
+edition = "2021"
+repository = "https://github.com/cloudflare/pingora"
+categories = ["compression"]
+keywords = ["http", "compression", "pingora"]
+exclude = ["samples/*"]
+description = """
+HTTP header (de)serialization and compression for Pingora.
+"""
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[lib]
+name = "pingora_header_serde"
+path = "src/lib.rs"
+
+[[bin]]
+name = "trainer"
+path = "src/trainer.rs"
+
+[dependencies]
+zstd = "0.9.0"
+zstd-safe = "4.1.1"
+http = { workspace = true }
+bytes = { workspace = true }
+httparse = { workspace = true }
+pingora-error = { version = "0.1.0", path = "../pingora-error" }
+pingora-http = { version = "0.1.0", path = "../pingora-http" }
+thread_local = "1.0"