aboutsummaryrefslogtreecommitdiffhomepage
path: root/pingora-header-serde/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pingora-header-serde/Cargo.toml')
-rw-r--r--pingora-header-serde/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/pingora-header-serde/Cargo.toml b/pingora-header-serde/Cargo.toml
new file mode 100644
index 0000000..2968cae
--- /dev/null
+++ b/pingora-header-serde/Cargo.toml
@@ -0,0 +1,32 @@
+[package]
+name = "pingora-header-serde"
+version = "0.1.0"
+authors = ["Yuchen Wu <[email protected]>"]
+license = "Apache-2.0"
+edition = "2021"
+repository = "https://github.com/cloudflare/pingora"
+categories = ["compression"]
+keywords = ["http", "compression", "pingora"]
+exclude = ["samples/*"]
+description = """
+HTTP header (de)serialization and compression for Pingora.
+"""
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[lib]
+name = "pingora_header_serde"
+path = "src/lib.rs"
+
+[[bin]]
+name = "trainer"
+path = "src/trainer.rs"
+
+[dependencies]
+zstd = "0.9.0"
+zstd-safe = "4.1.1"
+http = { workspace = true }
+bytes = { workspace = true }
+httparse = { workspace = true }
+pingora-error = { version = "0.1.0", path = "../pingora-error" }
+pingora-http = { version = "0.1.0", path = "../pingora-http" }
+thread_local = "1.0"