aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel García <[email protected]>2019-01-10 23:54:01 +0100
committerDaniel García <[email protected]>2019-01-10 23:54:01 +0100
commit1d034749f7b3a0c01d9e32287393498b64f50fde (patch)
tree041a655c0bd8fecfb218df6dad0394c057498fdd /Cargo.toml
parent08c55f636a85e1c5d51508dc0b6b370087fbd7bb (diff)
downloadvaultwarden-1.6.0.tar.gz
vaultwarden-1.6.0.zip
Fix AArch64 build by disabling yubico1.6.0
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 97a96c96..aa1f1438 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,7 +11,9 @@ publish = false
build = "build.rs"
[features]
+default = ["enable_yubikey"]
enable_syslog = ["syslog", "fern/syslog-4"]
+enable_yubikey = ["yubico"]
[dependencies]
# Web framework for nightly with a focus on ease-of-use, expressibility, and speed.
@@ -72,7 +74,7 @@ jsonwebtoken = "5.0.1"
u2f = "0.1.4"
# Yubico Library
-yubico = { version = "=0.4.0", features = ["online"], default-features = false }
+yubico = { version = "=0.4.0", features = ["online"], default-features = false, optional = true }
# A `dotenv` implementation for Rust
dotenv = { version = "0.13.0", default-features = false }