diff options
author | Mathijs van Veluw <[email protected]> | 2024-06-19 13:06:58 +0200 |
---|---|---|
committer | GitHub <[email protected]> | 2024-06-19 13:06:58 +0200 |
commit | 55fdee3bf8f45ccc7a5a188ab17855ac9866a979 (patch) | |
tree | 8df8d5bd8cb4f821bdb456b8e48b1619e9ec6b36 /Cargo.toml | |
parent | 377969ea6769bccd008203c5464eb361f685b787 (diff) | |
download | vaultwarden-55fdee3bf8f45ccc7a5a188ab17855ac9866a979.tar.gz vaultwarden-55fdee3bf8f45ccc7a5a188ab17855ac9866a979.zip |
Update crates, web-vault and GHA (#4648)
- Updated all crates including Diesel and the new mysqlclient-sys
- Updated the MSRV to v1.78 as that is what Diesel mandates
- Added the mimalloc crate as a patch for now to fix armv6 static builds
This probably makes #4606 possible
- Updated web-vault to v2024.5.1
- Updated GitHub Actions
Fixed an issue with the localhost images for extracting the musl binaries.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 25 |
1 files changed, 14 insertions, 11 deletions
@@ -3,7 +3,7 @@ name = "vaultwarden" version = "1.0.0" authors = ["Daniel GarcĂa <[email protected]>"] edition = "2021" -rust-version = "1.76.0" +rust-version = "1.78.0" resolver = "2" repository = "https://github.com/dani-garcia/vaultwarden" @@ -53,7 +53,7 @@ once_cell = "1.19.0" # Numerical libraries num-traits = "0.2.19" num-derive = "0.4.2" -bigdecimal = "0.4.3" +bigdecimal = "0.4.5" # Web framework rocket = { version = "0.5.1", features = ["tls", "json"], default-features = false } @@ -63,19 +63,19 @@ rocket_ws = { version ="0.1.1" } rmpv = "1.3.0" # MessagePack library # Concurrent HashMap used for WebSocket messaging and favicons -dashmap = "5.5.3" +dashmap = "6.0.0" # Async futures futures = "0.3.30" -tokio = { version = "1.37.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal", "net"] } +tokio = { version = "1.38.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal", "net"] } # A generic serialization/deserialization framework -serde = { version = "1.0.202", features = ["derive"] } +serde = { version = "1.0.203", features = ["derive"] } serde_json = "1.0.117" # A safe, extensible ORM and Query builder -diesel = { version = "2.1.6", features = ["chrono", "r2d2", "numeric"] } -diesel_migrations = "2.1.0" +diesel = { version = "2.2.1", features = ["chrono", "r2d2", "numeric"] } +diesel_migrations = "2.2.0" diesel_logger = { version = "0.3.0", optional = true } # Bundled/Static SQLite @@ -112,7 +112,7 @@ yubico = { version = "0.11.0", features = ["online-tokio"], default-features = f webauthn-rs = "0.3.2" # Handling of URL's for WebAuthn and favicons -url = "2.5.0" +url = "2.5.2" # Email libraries lettre = { version = "0.11.7", features = ["smtp-transport", "sendmail-transport", "builder", "serde", "tokio1-native-tls", "hostname", "tracing", "tokio1"], default-features = false } @@ -123,17 +123,17 @@ email_address = "0.2.4" handlebars = { version = "5.1.2", features = ["dir_source"] } # HTTP client (Used for favicons, version check, DUO and HIBP API) -reqwest = { version = "0.12.4", features = ["native-tls-alpn", "stream", "json", "gzip", "brotli", "socks", "cookies"] } +reqwest = { version = "0.12.5", features = ["native-tls-alpn", "stream", "json", "gzip", "brotli", "socks", "cookies"] } hickory-resolver = "0.24.1" # Favicon extraction libraries html5gum = "0.5.7" -regex = { version = "1.10.4", features = ["std", "perf", "unicode-perl"], default-features = false } +regex = { version = "1.10.5", features = ["std", "perf", "unicode-perl"], default-features = false } data-url = "0.3.1" bytes = "1.6.0" # Cache function results (Used for version check and favicon fetching) -cached = { version = "0.51.3", features = ["async"] } +cached = { version = "0.51.4", features = ["async"] } # Used for custom short lived cookie jar during favicon extraction cookie = "0.18.1" @@ -163,6 +163,9 @@ argon2 = "0.5.3" # Reading a password from the cli for generating the Argon2id ADMIN_TOKEN rpassword = "7.3.1" +# Patch mimalloc for now until a new version is released +[patch.crates-io] +mimalloc = { git = "https://github.com/purpleprotocol/mimalloc_rust.git", rev="992c9da4c5afba7fbf4c5815c43c8f0fbd2a8da6" } # Strip debuginfo from the release builds # The symbols are the provide better panic traces |