aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel <[email protected]>2024-12-10 18:59:28 +0200
committerGitHub <[email protected]>2024-12-10 17:59:28 +0100
commit620ad9233159c443acd91ec0c3828332b2c868cd (patch)
treec63274c096e2264b6ad226d987c803314dab1c40 /Cargo.toml
parentc9860af11ccedfa9b347e22652d75b862eeba391 (diff)
downloadvaultwarden-620ad9233159c443acd91ec0c3828332b2c868cd.tar.gz
vaultwarden-620ad9233159c443acd91ec0c3828332b2c868cd.zip
Update crates (#5268)
- fixes CVE-2024-12224
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cae715e6..63b04f9d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -53,7 +53,7 @@ once_cell = "1.20.2"
# Numerical libraries
num-traits = "0.2.19"
num-derive = "0.4.2"
-bigdecimal = "0.4.6"
+bigdecimal = "0.4.7"
# Web framework
rocket = { version = "0.5.1", features = ["tls", "json"], default-features = false }
@@ -89,7 +89,7 @@ ring = "0.17.8"
uuid = { version = "1.11.0", features = ["v4"] }
# Date and time libraries
-chrono = { version = "0.4.38", features = ["clock", "serde"], default-features = false }
+chrono = { version = "0.4.39", features = ["clock", "serde"], default-features = false }
chrono-tz = "0.10.0"
time = "0.3.37"
@@ -115,7 +115,7 @@ webauthn-rs = "0.3.2"
url = "2.5.4"
# Email libraries
-lettre = { version = "0.11.10", features = ["smtp-transport", "sendmail-transport", "builder", "serde", "tokio1-native-tls", "hostname", "tracing", "tokio1"], default-features = false }
+lettre = { version = "0.11.11", features = ["smtp-transport", "sendmail-transport", "builder", "serde", "tokio1-native-tls", "hostname", "tracing", "tokio1"], default-features = false }
percent-encoding = "2.3.1" # URL encoding library used for URL's in the emails
email_address = "0.2.9"
@@ -124,7 +124,7 @@ handlebars = { version = "6.2.0", features = ["dir_source"] }
# HTTP client (Used for favicons, version check, DUO and HIBP API)
reqwest = { version = "0.12.9", features = ["native-tls-alpn", "stream", "json", "gzip", "brotli", "socks", "cookies"] }
-hickory-resolver = "0.24.1"
+hickory-resolver = "0.24.2"
# Favicon extraction libraries
html5gum = "0.7.0"