aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel <[email protected]>2024-09-07 11:39:29 +0300
committerGitHub <[email protected]>2024-09-07 10:39:29 +0200
commit66baa5e7d844a455ffe18a89e9cb8521a013af14 (patch)
treeb68ac72aee38e3bdd53517da2cb70a1081151d88 /Cargo.toml
parent248e561b3fe6a8172751374df980c6cd43c841d5 (diff)
downloadvaultwarden-66baa5e7d844a455ffe18a89e9cb8521a013af14.tar.gz
vaultwarden-66baa5e7d844a455ffe18a89e9cb8521a013af14.zip
Update Rust version & crates (#4928)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 86ef304f..bca1aaeb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,7 +3,7 @@ name = "vaultwarden"
version = "1.0.0"
authors = ["Daniel GarcĂ­a <[email protected]>"]
edition = "2021"
-rust-version = "1.78.0"
+rust-version = "1.79.0"
resolver = "2"
repository = "https://github.com/dani-garcia/vaultwarden"
@@ -63,18 +63,18 @@ rocket_ws = { version ="0.1.1" }
rmpv = "1.3.0" # MessagePack library
# Concurrent HashMap used for WebSocket messaging and favicons
-dashmap = "6.0.1"
+dashmap = "6.1.0"
# Async futures
futures = "0.3.30"
tokio = { version = "1.40.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal", "net"] }
# A generic serialization/deserialization framework
-serde = { version = "1.0.209", features = ["derive"] }
-serde_json = "1.0.127"
+serde = { version = "1.0.210", features = ["derive"] }
+serde_json = "1.0.128"
# A safe, extensible ORM and Query builder
-diesel = { version = "2.2.3", features = ["chrono", "r2d2", "numeric"] }
+diesel = { version = "2.2.4", features = ["chrono", "r2d2", "numeric"] }
diesel_migrations = "2.2.0"
diesel_logger = { version = "0.3.0", optional = true }
@@ -115,12 +115,12 @@ webauthn-rs = "0.3.2"
url = "2.5.2"
# Email libraries
-lettre = { version = "0.11.7", features = ["smtp-transport", "sendmail-transport", "builder", "serde", "tokio1-native-tls", "hostname", "tracing", "tokio1"], default-features = false }
+lettre = { version = "0.11.8", features = ["smtp-transport", "sendmail-transport", "builder", "serde", "tokio1-native-tls", "hostname", "tracing", "tokio1"], default-features = false }
percent-encoding = "2.3.1" # URL encoding library used for URL's in the emails
email_address = "0.2.9"
# HTML Template library
-handlebars = { version = "6.0.0", features = ["dir_source"] }
+handlebars = { version = "6.1.0", features = ["dir_source"] }
# HTTP client (Used for favicons, version check, DUO and HIBP API)
reqwest = { version = "0.12.7", features = ["native-tls-alpn", "stream", "json", "gzip", "brotli", "socks", "cookies"] }