diff options
author | BlackDex <[email protected]> | 2023-06-11 18:11:09 +0200 |
---|---|---|
committer | BlackDex <[email protected]> | 2023-08-12 12:29:33 +0200 |
commit | aaeae16983d83ce0cec3f1b4c841eb35b6555f43 (patch) | |
tree | 3df8ea4d9707f22c3653f87c4a385a6839e1ad22 /Cargo.toml | |
parent | 3dbfc484a54c41d1759646444b439da06445060b (diff) | |
download | vaultwarden-aaeae16983d83ce0cec3f1b4c841eb35b6555f43.tar.gz vaultwarden-aaeae16983d83ce0cec3f1b4c841eb35b6555f43.zip |
Update images to Bookworm and PQ15
This PR updates the base images to use Debian Bookworm as base image. Also the MUSL/Alpine builds now use OpenSSLv3 and PostgreSQL v15.
The GHA Workflows are updated to use Ubuntu 22.04 to better match the versions of Debian Bookworm.
Also:
- Enabled spares crate registry
- Updated workflow actions
- Updated Rust to v1.71.0
- The rust-musl images now use musl v1.2.3 for the 32bit arch's if the Rust version is v1.71.0 or higher.
The 64bit arch's already used musl v1.2.3.
- Updated crates.
Improves / Closes #3434
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 32 |
1 files changed, 16 insertions, 16 deletions
@@ -3,7 +3,7 @@ name = "vaultwarden" version = "1.0.0" authors = ["Daniel GarcĂa <[email protected]>"] edition = "2021" -rust-version = "1.68.2" +rust-version = "1.69.0" resolver = "2" repository = "https://github.com/dani-garcia/vaultwarden" @@ -51,7 +51,7 @@ dotenvy = { version = "0.15.7", default-features = false } once_cell = "1.18.0" # Numerical libraries -num-traits = "0.2.15" +num-traits = "0.2.16" num-derive = "0.4.0" # Web framework @@ -61,18 +61,18 @@ rocket_ws = { git = 'https://github.com/SergioBenitez/Rocket', rev = "ce441b5f46 # WebSockets libraries tokio-tungstenite = "0.19.0" -rmpv = "1.0.0" # MessagePack library +rmpv = "1.0.1" # MessagePack library # Concurrent HashMap used for WebSocket messaging and favicons -dashmap = "5.4.0" +dashmap = "5.5.0" # Async futures futures = "0.3.28" -tokio = { version = "1.29.1", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] } +tokio = { version = "1.30.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] } # A generic serialization/deserialization framework -serde = { version = "1.0.166", features = ["derive"] } -serde_json = "1.0.99" +serde = { version = "1.0.183", features = ["derive"] } +serde_json = "1.0.104" # A safe, extensible ORM and Query builder diesel = { version = "2.1.0", features = ["chrono", "r2d2"] } @@ -87,12 +87,12 @@ rand = { version = "0.8.5", features = ["small_rng"] } ring = "0.16.20" # UUID generation -uuid = { version = "1.4.0", features = ["v4"] } +uuid = { version = "1.4.1", features = ["v4"] } # Date and time libraries chrono = { version = "0.4.26", features = ["clock", "serde"], default-features = false } chrono-tz = "0.8.3" -time = "0.3.22" +time = "0.3.25" # Job scheduler job_scheduler_ng = "2.0.4" @@ -127,8 +127,8 @@ handlebars = { version = "4.3.7", features = ["dir_source"] } reqwest = { version = "0.11.18", features = ["stream", "json", "gzip", "brotli", "socks", "cookies", "trust-dns"] } # Favicon extraction libraries -html5gum = "0.5.3" -regex = { version = "1.8.4", features = ["std", "perf", "unicode-perl"], default-features = false } +html5gum = "0.5.7" +regex = { version = "1.9.3", features = ["std", "perf", "unicode-perl"], default-features = false } data-url = "0.3.0" bytes = "1.4.0" @@ -140,17 +140,17 @@ cookie = "0.16.2" cookie_store = "0.19.1" # Used by U2F, JWT and PostgreSQL -openssl = "0.10.55" +openssl = "0.10.56" # CLI argument parsing pico-args = "0.5.0" # Macro ident concatenation -paste = "1.0.13" -governor = "0.5.1" +paste = "1.0.14" +governor = "0.6.0" # Check client versions for specific features. -semver = "1.0.17" +semver = "1.0.18" # Allow overriding the default memory allocator # Mainly used for the musl builds, since the default musl malloc is very slow @@ -158,7 +158,7 @@ mimalloc = { version = "0.1.37", features = ["secure"], default-features = false which = "4.4.0" # Argon2 library with support for the PHC format -argon2 = "0.5.0" +argon2 = "0.5.1" # Reading a password from the cli for generating the Argon2id ADMIN_TOKEN rpassword = "7.2.0" |