aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml26
1 files changed, 13 insertions, 13 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 54feb671..4eab1ef9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,7 +3,7 @@ name = "vaultwarden"
version = "1.0.0"
authors = ["Daniel GarcĂ­a <[email protected]>"]
edition = "2021"
-rust-version = "1.60.0"
+rust-version = "1.61.0"
resolver = "2"
repository = "https://github.com/dani-garcia/vaultwarden"
@@ -50,7 +50,7 @@ backtrace = "0.3.67" # Logging panics to logfile instead stderr only
dotenvy = { version = "0.15.6", default-features = false }
# Lazy initialization
-once_cell = "1.16.0"
+once_cell = "1.17.0"
# Numerical libraries
num-traits = "0.2.15"
@@ -66,11 +66,11 @@ dashmap = "5.4.0"
# Async futures
futures = "0.3.25"
-tokio = { version = "1.23.0", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] }
+tokio = { version = "1.24.1", features = ["rt-multi-thread", "fs", "io-util", "parking_lot", "time", "signal"] }
# A generic serialization/deserialization framework
-serde = { version = "1.0.150", features = ["derive"] }
-serde_json = "1.0.89"
+serde = { version = "1.0.152", features = ["derive"] }
+serde_json = "1.0.91"
# A safe, extensible ORM and Query builder
diesel = { version = "2.0.2", features = ["chrono", "r2d2"] }
@@ -119,38 +119,38 @@ percent-encoding = "2.2.0" # URL encoding library used for URL's in the emails
email_address = "0.2.4"
# Template library
-handlebars = { version = "4.3.5", features = ["dir_source"] }
+handlebars = { version = "4.3.6", features = ["dir_source"] }
# HTTP client
reqwest = { version = "0.11.13", features = ["stream", "json", "gzip", "brotli", "socks", "cookies", "trust-dns"] }
# For favicon extraction from main website
html5gum = "0.5.2"
-regex = { version = "1.7.0", features = ["std", "perf", "unicode-perl"], default-features = false }
+regex = { version = "1.7.1", features = ["std", "perf", "unicode-perl"], default-features = false }
data-url = "0.2.0"
bytes = "1.3.0"
-cached = "0.40.0"
+cached = "0.42.0"
# Used for custom short lived cookie jar during favicon extraction
-cookie = "0.16.1"
+cookie = "0.16.2"
cookie_store = "0.19.0"
# Used by U2F, JWT and Postgres
-openssl = "0.10.44"
+openssl = "0.10.45"
# CLI argument parsing
pico-args = "0.5.0"
# Macro ident concatenation
-paste = "1.0.10"
+paste = "1.0.11"
governor = "0.5.1"
# Check client versions for specific features.
-semver = "1.0.14"
+semver = "1.0.16"
# Allow overriding the default memory allocator
# Mainly used for the musl builds, since the default musl malloc is very slow
-mimalloc = { version = "0.1.32", features = ["secure"], default-features = false, optional = true }
+mimalloc = { version = "0.1.34", features = ["secure"], default-features = false, optional = true }
# Strip debuginfo from the release builds
# Also enable thin LTO for some optimizations