aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorAndrea Pappacoda <[email protected]>2021-10-10 21:28:28 +0200
committerAndrea Pappacoda <[email protected]>2021-10-10 21:30:09 +0200
commitb29e471ea5d31e9384b5f77dd2af9e7ee215d92b (patch)
tree09112854e3ef30204a920bd955e3792b4dc05ff3 /meson.build
parentcecd204a506a723950932629bff2dff35f0ebe84 (diff)
downloadxbyak-b29e471ea5d31e9384b5f77dd2af9e7ee215d92b.tar.gz
xbyak-b29e471ea5d31e9384b5f77dd2af9e7ee215d92b.zip
build(meson): fix CMake Config file include dir
I previously set the path to ${CMAKE_CURRENT_LIST_FILE}/include, that was wrong and ended up pointing to a nonexistent directory.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 59d0051..1634fd0 100644
--- a/meson.build
+++ b/meson.build
@@ -35,6 +35,7 @@ if meson.version().version_compare('>=0.50.0')
cmake_conf = configuration_data()
cmake_conf.set('TARGET_NAME', meson.project_name() + '::' + meson.project_name())
+ cmake_conf.set('ABSOLUTE_INCLUDE_DIR', get_option('prefix')/get_option('includedir'))
cmake.configure_package_config_file(
name: meson.project_name(),