aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2024-08-04 15:19:37 +0300
committerMihai Fufezan <[email protected]>2024-08-04 15:19:37 +0300
commit5dd2c27b631f16e49a2c6e6cbbefba9fa50bf543 (patch)
treecb145c5eb46250dd7abece115524dbc5ebba46d7 /CMakeLists.txt
parent4ae89e1f227d8b19afe8c692033ab894e053c7ec (diff)
downloadHyprland-5dd2c27b631f16e49a2c6e6cbbefba9fa50bf543.tar.gz
Hyprland-5dd2c27b631f16e49a2c6e6cbbefba9fa50bf543.zip
CMake, Meson: install config and wallpapers to DATADIR/hypr
OpenGL: get wallpapers dir from DATAROOTDIR
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 11 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e284cb68..fa58b63d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -262,9 +262,11 @@ endfunction()
target_link_libraries(Hyprland OpenGL::EGL OpenGL::GL Threads::Threads
libudis86 uuid)
-protocolnew("subprojects/hyprland-protocols/protocols" "hyprland-global-shortcuts-v1" true)
+protocolnew("subprojects/hyprland-protocols/protocols"
+ "hyprland-global-shortcuts-v1" true)
protocolnew("unstable/text-input" "text-input-unstable-v1" false)
-protocolnew("subprojects/hyprland-protocols/protocols" "hyprland-toplevel-export-v1" true)
+protocolnew("subprojects/hyprland-protocols/protocols"
+ "hyprland-toplevel-export-v1" true)
protocolnew("protocols" "wlr-screencopy-unstable-v1" true)
protocolnew("protocols" "wlr-gamma-control-unstable-v1" true)
protocolnew("protocols" "wlr-foreign-toplevel-management-unstable-v1" true)
@@ -326,19 +328,22 @@ install(
# session file
install(FILES ${CMAKE_SOURCE_DIR}/example/hyprland.desktop
- DESTINATION ${CMAKE_INSTALL_DATADIR}/wayland-sessions)
+ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/wayland-sessions)
+
+# allow Hyprland to find wallpapers
+add_compile_definitions(DATAROOTDIR="${CMAKE_INSTALL_FULL_DATAROOTDIR}")
# wallpapers
file(GLOB_RECURSE WALLPAPERS "assets/wall*")
-install(FILES ${WALLPAPERS} DESTINATION ${CMAKE_INSTALL_DATADIR}/hyprland)
+install(FILES ${WALLPAPERS} DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/hypr)
# default config
install(FILES ${CMAKE_SOURCE_DIR}/example/hyprland.conf
- DESTINATION ${CMAKE_INSTALL_DATADIR}/hyprland)
+ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/hypr)
# portal config
install(FILES ${CMAKE_SOURCE_DIR}/assets/hyprland-portals.conf
- DESTINATION ${CMAKE_INSTALL_DATADIR}/xdg-desktop-portal)
+ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/xdg-desktop-portal)
# man pages
file(GLOB_RECURSE MANPAGES "docs/*.1")