aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2024-11-11 10:05:01 +0200
committerMihai Fufezan <[email protected]>2024-11-11 16:52:42 +0200
commitff411658e8b217cadf69887f7313d6fd2fc417f2 (patch)
tree83fc695b0c349814dae3959b973c0694ac9ddab6 /CMakeLists.txt
parent943c7d18cc7c9300e1a6b4b859558b8c7ac540cd (diff)
downloadHyprland-ff411658e8b217cadf69887f7313d6fd2fc417f2.tar.gz
Hyprland-ff411658e8b217cadf69887f7313d6fd2fc417f2.zip
Lock uwsm desktop file behind feature flag
The file in the repo cannot be used in NixOS due to missing full paths, and the fact that `uwsm` does not have access to `PATH` to find the listed binaries. Might be useful in other situations as well.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d337680f..117932d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -224,8 +224,13 @@ else()
add_compile_definitions(USES_SYSTEMD)
# session file -uwsm
- install(FILES ${CMAKE_SOURCE_DIR}/systemd/hyprland-uwsm.desktop
- DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/wayland-sessions)
+ if(NO_UWSM)
+ message(STATUS "UWSM support is disabled...")
+ else()
+ message(STATUS "UWSM support is enabled (NO_UWSM not defined)...")
+ install(FILES ${CMAKE_SOURCE_DIR}/systemd/hyprland-uwsm.desktop
+ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/wayland-sessions)
+ endif()
endif()
set(CPACK_PROJECT_NAME ${PROJECT_NAME})