diff options
author | Narice <[email protected]> | 2022-05-16 16:01:28 +0100 |
---|---|---|
committer | Narice <[email protected]> | 2022-05-16 16:01:28 +0100 |
commit | 0aacdbdfb6e4b791d294e693d598dce7fd4cb50c (patch) | |
tree | c1dde1d4f122870e708da66b8c73d1f93f2909fd /flake.nix | |
parent | 23c3534197f54e2f74b791ce2a8857b25bbba259 (diff) | |
download | Hyprland-0aacdbdfb6e4b791d294e693d598dce7fd4cb50c.tar.gz Hyprland-0aacdbdfb6e4b791d294e693d598dce7fd4cb50c.zip |
Fixed build for Nix/OS users
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 16 |
1 files changed, 12 insertions, 4 deletions
@@ -3,17 +3,23 @@ description = "Hyprland is a dynamic tiling Wayland compositor that doesn't sacrifice on its looks."; inputs = { - nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable"; + nixpkgs.url = "github:NixOS/nixpkgs/nixos-21.11"; utils.url = "github:numtide/flake-utils"; nixpkgs-wayland.url = "github:nix-community/nixpkgs-wayland"; + wlroots-git = { + url = "gitlab:wlroots/wlroots?host=gitlab.freedesktop.org"; + flake = false; + }; }; - outputs = { self, nixpkgs, utils, nixpkgs-wayland }: + outputs = { self, nixpkgs, utils, nixpkgs-wayland, wlroots-git }: { overlay = final: prev: { hyprland = prev.callPackage self { src = self; - wlroots = (nixpkgs-wayland.overlays.default final prev).wlroots; + wlroots = (nixpkgs-wayland.overlays.default final prev).wlroots.overrideAttrs (prev: rec { + src = wlroots-git; + }); }; }; overlays.default = self.overlay; @@ -23,7 +29,9 @@ packages = { hyprland = pkgs.callPackage self { src = self; - inherit (nixpkgs-wayland.packages.${system}) wlroots; + wlroots = nixpkgs-wayland.packages.${system}.wlroots.overrideAttrs (prev: rec { + src = wlroots-git; + }); }; }; defaultPackage = packages.hyprland; |