aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorJörg Thalheim <[email protected]>2024-06-06 10:07:53 +0200
committerMihai Fufezan <[email protected]>2024-09-26 21:17:07 +0300
commit32a8caf7e7a0609629eb08c91de9f9b23a10c455 (patch)
tree1d4fbc440253b57ae90356b11b2e65e80c5438f3 /flake.nix
parentcaaa9b11e4763ed0367f81bf97ceaad5175806fc (diff)
downloadHyprland-32a8caf7e7a0609629eb08c91de9f9b23a10c455.tar.gz
Hyprland-32a8caf7e7a0609629eb08c91de9f9b23a10c455.zip
Nix: also test cross build
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index ef48b2d1..eca45675 100644
--- a/flake.nix
+++ b/flake.nix
@@ -67,6 +67,15 @@
hyprland-extras
];
});
+ pkgsCrossFor = eachSystem (system: crossSystem:
+ import nixpkgs {
+ localSystem = system;
+ crossSystem = crossSystem;
+ overlays = with self.overlays; [
+ hyprland-packages
+ hyprland-extras
+ ];
+ });
in {
overlays = import ./nix/overlays.nix {inherit self lib inputs;};
@@ -92,6 +101,7 @@
xdg-desktop-portal-hyprland
;
+ hyprland-cross = (pkgsCrossFor.${system} "aarch64-linux").hyprland;
});
devShells = eachSystem (system: {