aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorJames Reynolds <[email protected]>2022-06-06 10:20:56 +0100
committerJames Reynolds <[email protected]>2022-06-06 10:20:56 +0100
commit3d4832990c8770c789c359cdffc505ddb31ca83d (patch)
tree43ef74eea99179bbde3ee89d10c24da7e5ea6017 /flake.nix
parent84a0fa0f34ccc82c1bbb961bac0dbe81c82e999c (diff)
downloadHyprland-3d4832990c8770c789c359cdffc505ddb31ca83d.tar.gz
Hyprland-3d4832990c8770c789c359cdffc505ddb31ca83d.zip
Fix error: attribute 'lastModifiedDate' missing
Only applies to some versions of flakes, tested on nix 2.8.1.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index aee2abd6..a756ed90 100644
--- a/flake.nix
+++ b/flake.nix
@@ -33,11 +33,11 @@
in {
packages = genSystems (system: {
wlroots = pkgsFor.${system}.wlroots.overrideAttrs (prev: {
- version = mkVersion inputs.wlroots.lastModifiedDate;
+ version = mkVersion (toString (inputs.wlroots.lastModifiedDate or inputs.wlroots.lastModified or "19700101"));
src = inputs.wlroots;
});
default = pkgsFor.${system}.callPackage ./nix/default.nix {
- version = mkVersion self.lastModifiedDate;
+ version = mkVersion (toString (self.lastModifiedDate or self.lastModified or "19700101"));
inherit (self.packages.${system}) wlroots;
};
});