aboutsummaryrefslogtreecommitdiffhomepage
path: root/hyprctl/CMakeLists.txt
diff options
context:
space:
mode:
authorVaxry <[email protected]>2024-06-11 17:17:45 +0200
committerGitHub <[email protected]>2024-06-11 17:17:45 +0200
commit8c64a4bad710fb18e9b84812bd680a89d1e93661 (patch)
tree2439b8408abd8e14f6af35ef9cfbeb7c51429f99 /hyprctl/CMakeLists.txt
parent1f46296ea05f9a8e6020ab694b531c91a1abdfa6 (diff)
downloadHyprland-8c64a4bad710fb18e9b84812bd680a89d1e93661.tar.gz
Hyprland-8c64a4bad710fb18e9b84812bd680a89d1e93661.zip
core: move to hyprutils for utils (#6385)
* core: move to hyprutils for utils Nix: add hyprutils dep * Meson: add hyprutils dep * flake.lock: update --------- Co-authored-by: Mihai Fufezan <[email protected]>
Diffstat (limited to 'hyprctl/CMakeLists.txt')
-rw-r--r--hyprctl/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/hyprctl/CMakeLists.txt b/hyprctl/CMakeLists.txt
index 6f70ace8..64b983e6 100644
--- a/hyprctl/CMakeLists.txt
+++ b/hyprctl/CMakeLists.txt
@@ -5,8 +5,12 @@ project(
DESCRIPTION "Control utility for Hyprland"
)
+pkg_check_modules(deps REQUIRED IMPORTED_TARGET hyprutils>=0.1.1)
+
add_executable(hyprctl "main.cpp")
+target_link_libraries(hyprctl PUBLIC PkgConfig::deps)
+
# binary
install(TARGETS hyprctl)