aboutsummaryrefslogtreecommitdiffhomepage
path: root/hyprpm/CMakeLists.txt
diff options
context:
space:
mode:
authorVaxry <[email protected]>2024-06-11 17:17:45 +0200
committerGitHub <[email protected]>2024-06-11 17:17:45 +0200
commit8c64a4bad710fb18e9b84812bd680a89d1e93661 (patch)
tree2439b8408abd8e14f6af35ef9cfbeb7c51429f99 /hyprpm/CMakeLists.txt
parent1f46296ea05f9a8e6020ab694b531c91a1abdfa6 (diff)
downloadHyprland-8c64a4bad710fb18e9b84812bd680a89d1e93661.tar.gz
Hyprland-8c64a4bad710fb18e9b84812bd680a89d1e93661.zip
core: move to hyprutils for utils (#6385)
* core: move to hyprutils for utils Nix: add hyprutils dep * Meson: add hyprutils dep * flake.lock: update --------- Co-authored-by: Mihai Fufezan <[email protected]>
Diffstat (limited to 'hyprpm/CMakeLists.txt')
-rw-r--r--hyprpm/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/hyprpm/CMakeLists.txt b/hyprpm/CMakeLists.txt
index 8b6a8320..692e8da1 100644
--- a/hyprpm/CMakeLists.txt
+++ b/hyprpm/CMakeLists.txt
@@ -9,11 +9,11 @@ file(GLOB_RECURSE SRCFILES CONFIGURE_DEPENDS "src/*.cpp")
set(CMAKE_CXX_STANDARD 23)
-pkg_check_modules(tomlplusplus REQUIRED IMPORTED_TARGET tomlplusplus)
+pkg_check_modules(deps REQUIRED IMPORTED_TARGET tomlplusplus hyprutils>=0.1.1)
add_executable(hyprpm ${SRCFILES})
-target_link_libraries(hyprpm PUBLIC PkgConfig::tomlplusplus)
+target_link_libraries(hyprpm PUBLIC PkgConfig::deps)
# binary
install(TARGETS hyprpm)