aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2024-08-04 15:19:37 +0300
committerMihai Fufezan <[email protected]>2024-08-04 15:19:37 +0300
commit5dd2c27b631f16e49a2c6e6cbbefba9fa50bf543 (patch)
treecb145c5eb46250dd7abece115524dbc5ebba46d7 /meson.build
parent4ae89e1f227d8b19afe8c692033ab894e053c7ec (diff)
downloadHyprland-5dd2c27b631f16e49a2c6e6cbbefba9fa50bf543.tar.gz
Hyprland-5dd2c27b631f16e49a2c6e6cbbefba9fa50bf543.zip
CMake, Meson: install config and wallpapers to DATADIR/hypr
OpenGL: get wallpapers dir from DATAROOTDIR
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4446ea0f..886f4f9c 100644
--- a/meson.build
+++ b/meson.build
@@ -9,6 +9,7 @@ project('Hyprland', 'cpp', 'c',
'cpp_std=c++23',
])
+datarootdir = '-DDATAROOTDIR="' + get_option('prefix') / get_option('datadir') + '"'
add_project_arguments(
[
'-Wno-unused-parameter',
@@ -16,6 +17,7 @@ add_project_arguments(
'-Wno-missing-field-initializers',
'-Wno-narrowing',
'-Wno-pointer-arith',
+ datarootdir,
],
language: 'cpp')