aboutsummaryrefslogtreecommitdiffhomepage
path: root/nix/default.nix
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2024-06-17 13:14:26 +0300
committerMihai Fufezan <[email protected]>2024-06-17 13:14:27 +0300
commit14ab0ecc5eb3c437dd62f92629fc29e33679043b (patch)
treea35db1b89872d372416dea7c6cd573f9997366f4 /nix/default.nix
parent9cb3bf1cac1a38fbac3942a60415d7050ffcd2cb (diff)
downloadHyprland-14ab0ecc5eb3c437dd62f92629fc29e33679043b.tar.gz
Hyprland-14ab0ecc5eb3c437dd62f92629fc29e33679043b.zip
Nix: don't strip in debug builds
Strip in Release builds, as the non-stripped binary is almost 500MB.
Diffstat (limited to 'nix/default.nix')
-rw-r--r--nix/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nix/default.nix b/nix/default.nix
index 6b5068bc..a2302688 100644
--- a/nix/default.nix
+++ b/nix/default.nix
@@ -152,7 +152,7 @@ assert lib.assertMsg (!hidpiXWayland) "The option `hidpiXWayland` has been remov
else "RelWithDebInfo";
# we want as much debug info as possible
- dontStrip = true;
+ dontStrip = debug;
cmakeFlags = [
(lib.cmakeBool "NO_XWAYLAND" (!enableXWayland))