aboutsummaryrefslogtreecommitdiffhomepage
path: root/nix/hm-module.nix
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2022-09-03 23:15:58 +0300
committerMihai Fufezan <[email protected]>2022-09-03 23:22:39 +0300
commit1664f81cae6bd0e159de835f09d4f0d7105fe07e (patch)
tree47856921ce400f589546020c23554b8f3777db4e /nix/hm-module.nix
parentc425e620af37e4ccc63d534982bc1056976a1554 (diff)
downloadHyprland-1664f81cae6bd0e159de835f09d4f0d7105fe07e.tar.gz
Hyprland-1664f81cae6bd0e159de835f09d4f0d7105fe07e.zip
Nix: revert HM module import fix
fixes #619
Diffstat (limited to 'nix/hm-module.nix')
-rw-r--r--nix/hm-module.nix16
1 files changed, 8 insertions, 8 deletions
diff --git a/nix/hm-module.nix b/nix/hm-module.nix
index d34d604f..0f4e8a3b 100644
--- a/nix/hm-module.nix
+++ b/nix/hm-module.nix
@@ -10,14 +10,6 @@ self: {
hidpiXWayland = cfg.xwayland.hidpi;
};
in {
- imports = [
- (
- lib.mkRenamedOptionModule
- ["wayland" "windowManager" "hyprland" "xwayland"]
- ["wayland" "windowManager" "hyprland" "xwayland" "enable"]
- )
- ];
-
options.wayland.windowManager.hyprland = {
enable = lib.mkEnableOption "hyprland wayland compositor";
package = lib.mkOption {
@@ -74,6 +66,14 @@ in {
Extra configuration lines to add to ~/.config/hypr/hyprland.conf.
'';
};
+
+ imports = [
+ (
+ lib.mkRenamedOptionModule
+ ["wayland" "windowManager" "hyprland" "xwayland"]
+ ["wayland" "windowManager" "hyprland" "xwayland" "enable"]
+ )
+ ];
};
config = lib.mkIf cfg.enable {