aboutsummaryrefslogtreecommitdiffhomepage
path: root/nix/overlays.nix
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2024-11-07 10:52:12 +0200
committerMihai Fufezan <[email protected]>2024-11-07 10:52:12 +0200
commited729b41319cc1129d5380d6e1055db60f01ea9d (patch)
tree3ad76b4c3023a836abd65376205aac91cc0e2939 /nix/overlays.nix
parent86a3d41051515f416f5eef2d4b6076ac2e8d16af (diff)
downloadHyprland-keepDebugInfo.tar.gz
Hyprland-keepDebugInfo.zip
Nix: build aquamarine and hyprutils in debug when using hyprland-debugkeepDebugInfo
Diffstat (limited to 'nix/overlays.nix')
-rw-r--r--nix/overlays.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/nix/overlays.nix b/nix/overlays.nix
index b1eb66ad..a7106315 100644
--- a/nix/overlays.nix
+++ b/nix/overlays.nix
@@ -40,7 +40,13 @@ in {
inherit date;
};
hyprland-unwrapped = final.hyprland.override {wrapRuntimeDeps = false;};
- hyprland-debug = final.hyprland.override {debug = true;};
+
+ # Build major libs with debug to get as much info as possible in a stacktrace
+ hyprland-debug = final.hyprland.override {
+ aquamarine = final.aquamarine.override {debug = true;};
+ hyprutils = final.hyprutils.override {debug = true;};
+ debug = true;
+ };
hyprland-legacy-renderer = final.hyprland.override {legacyRenderer = true;};
# deprecated packages