aboutsummaryrefslogtreecommitdiffhomepage
path: root/nix/overlays.nix
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2024-09-22 21:20:35 +0300
committerMihai Fufezan <[email protected]>2024-09-27 00:07:52 +0300
commit27211c71e92e1bacf111d8a815e958f80969ce6e (patch)
treeeb3600df8383225540304fbb35e1ba8fa90fc5e7 /nix/overlays.nix
parent14942bca60cc7d85e8238a151bd444112601ebe6 (diff)
downloadHyprland-27211c71e92e1bacf111d8a815e958f80969ce6e.tar.gz
Hyprland-27211c71e92e1bacf111d8a815e958f80969ce6e.zip
Meson: try to find udis86 through pkgconfig, fallback to subproject
Only the fork provides a .pc file, so there's no risk of linking the wrong lib version. If pkg-config can't find it (most cases), fall back to using the subproject through the wrap file.
Diffstat (limited to 'nix/overlays.nix')
-rw-r--r--nix/overlays.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/nix/overlays.nix b/nix/overlays.nix
index 71b5f59f..2b2788e7 100644
--- a/nix/overlays.nix
+++ b/nix/overlays.nix
@@ -26,6 +26,7 @@ in {
inputs.hyprlang.overlays.default
inputs.hyprutils.overlays.default
inputs.hyprwayland-scanner.overlays.default
+ self.overlays.udis86
# Hyprland packages themselves
(final: prev: let
@@ -64,4 +65,20 @@ in {
hyprland-extras = lib.composeManyExtensions [
inputs.xdph.overlays.xdg-desktop-portal-hyprland
];
+
+ # udis86 from nixpkgs is too old, and also does not provide a .pc file
+ # this version is the one used in the git submodule, and allows us to
+ # fetch the source without '?submodules=1'
+ udis86 = final: prev: {
+ udis86-hyprland = prev.udis86.overrideAttrs (self: super: {
+ src = final.fetchFromGitHub {
+ owner = "canihavesomecoffee";
+ repo = "udis86";
+ rev = "5336633af70f3917760a6d441ff02d93477b0c86";
+ hash = "sha256-HifdUQPGsKQKQprByeIznvRLONdOXeolOsU5nkwIv3g=";
+ };
+
+ patches = [];
+ });
+ };
}