aboutsummaryrefslogtreecommitdiffhomepage
path: root/systemd/meson.build
diff options
context:
space:
mode:
authorMihai Fufezan <[email protected]>2024-11-11 10:05:01 +0200
committerMihai Fufezan <[email protected]>2024-11-11 16:52:42 +0200
commitff411658e8b217cadf69887f7313d6fd2fc417f2 (patch)
tree83fc695b0c349814dae3959b973c0694ac9ddab6 /systemd/meson.build
parent943c7d18cc7c9300e1a6b4b859558b8c7ac540cd (diff)
downloadHyprland-ff411658e8b217cadf69887f7313d6fd2fc417f2.tar.gz
Hyprland-ff411658e8b217cadf69887f7313d6fd2fc417f2.zip
Lock uwsm desktop file behind feature flag
The file in the repo cannot be used in NixOS due to missing full paths, and the fact that `uwsm` does not have access to `PATH` to find the listed binaries. Might be useful in other situations as well.
Diffstat (limited to 'systemd/meson.build')
-rw-r--r--systemd/meson.build12
1 files changed, 7 insertions, 5 deletions
diff --git a/systemd/meson.build b/systemd/meson.build
index 731f04e3..bc62e95a 100644
--- a/systemd/meson.build
+++ b/systemd/meson.build
@@ -1,5 +1,7 @@
-install_data(
- 'hyprland-uwsm.desktop',
- install_dir: join_paths(get_option('datadir'), 'wayland-sessions'),
- install_tag: 'runtime',
-)
+if (get_option('uwsm').allowed())
+ install_data(
+ 'hyprland-uwsm.desktop',
+ install_dir: join_paths(get_option('datadir'), 'wayland-sessions'),
+ install_tag: 'runtime',
+ )
+endif