aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandre Bouvier <[email protected]>2022-11-28 00:06:31 +0100
committermerry <[email protected]>2022-12-31 23:14:38 +0000
commit4bf4d6565e503df0a6fc3e2dd75c722591b19ec2 (patch)
tree019d65937d6a073da4a972516c56f39d8967bd10 /CMakeLists.txt
parent63ebed57600ac0236cd76d707e3b4d69215ede19 (diff)
downloaddynarmic-4bf4d6565e503df0a6fc3e2dd75c722591b19ec2.tar.gz
dynarmic-4bf4d6565e503df0a6fc3e2dd75c722591b19ec2.zip
cmake: allow shared llvm linking
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a8f7a175..23e62ca0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -139,9 +139,6 @@ endif()
if (DYNARMIC_USE_LLVM)
find_package(LLVM REQUIRED CONFIG)
- include_directories(${LLVM_INCLUDE_DIRS})
- add_definitions(-DDYNARMIC_USE_LLVM ${LLVM_DEFINITIONS})
- llvm_map_components_to_libnames(llvm_libs armdesc armdisassembler aarch64desc aarch64disassembler x86desc x86disassembler)
endif()
if (DYNARMIC_TESTS)