aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMerry <[email protected]>2023-01-06 14:27:06 +0000
committerMerry <[email protected]>2023-01-06 14:27:06 +0000
commit6b41b5be07d51d8b1e2103782bb28d4873a3ebfa (patch)
tree929e8fe32f0e68657fc1fea9e392afccfe2e66a4 /CMakeLists.txt
parentc72ee5473b5b11ac110e86cc9544cab5159ccce8 (diff)
downloaddynarmic-6b41b5be07d51d8b1e2103782bb28d4873a3ebfa.tar.gz
dynarmic-6b41b5be07d51d8b1e2103782bb28d4873a3ebfa.zip
CMakeLists: Support multi-architecture builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 920cf2ba..7e36443a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -134,7 +134,7 @@ find_package(fmt 9 QUIET)
find_package(mcl 0.1.12 EXACT QUIET)
find_package(tsl-robin-map QUIET)
-if (ARCHITECTURE STREQUAL "x86" OR ARCHITECTURE STREQUAL "x86_64")
+if ("x86_64" IN_LIST ARCHITECTURE)
find_package(xbyak 6 QUIET)
find_package(Zydis 4 QUIET)
endif()