aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMerry <[email protected]>2023-09-01 21:09:34 +0100
committerMerry <[email protected]>2023-09-01 21:09:34 +0100
commit96e179465884be74987d5847d6741cdabdfe1b48 (patch)
tree1ac2cabce32e036e72387b23a26a3225da30b522 /CMakeLists.txt
parent29dde29560e04bce126795de8eeaef52221b9d22 (diff)
downloaddynarmic-96e179465884be74987d5847d6741cdabdfe1b48.tar.gz
dynarmic-96e179465884be74987d5847d6741cdabdfe1b48.zip
CMakeLists: Only enable -pendantic-errors when DYNARMIC_WARNINGS_AS_ERRORS enabled
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eb924099..a8893f3a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -91,11 +91,11 @@ else()
-Wextra
-Wcast-qual
-pedantic
- -pedantic-errors
-Wno-missing-braces)
if (DYNARMIC_WARNINGS_AS_ERRORS)
list(APPEND DYNARMIC_CXX_FLAGS
+ -pedantic-errors
-Werror)
endif()