aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorameerj <[email protected]>2022-11-21 22:45:11 -0500
committermerry <[email protected]>2022-11-22 17:49:13 +0000
commita5b57bb9cd1500a6e0a3c800b35c1984211dff1d (patch)
treeb20abd1095c0d55ee2ced483c6ef7041bcda37ea /CMakeLists.txt
parentdf72827b091760eebfd200e9fcdf0a5915f0fc3c (diff)
downloaddynarmic-a5b57bb9cd1500a6e0a3c800b35c1984211dff1d.tar.gz
dynarmic-a5b57bb9cd1500a6e0a3c800b35c1984211dff1d.zip
CMake: Add option to use precompiled headers
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ac142d12..cf3e69a5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,7 @@ option(DYNARMIC_IGNORE_ASSERTS "Ignore asserts" OFF)
option(DYNARMIC_TESTS "Build tests" ${MASTER_PROJECT})
option(DYNARMIC_TESTS_USE_UNICORN "Enable fuzzing tests against unicorn" OFF)
option(DYNARMIC_USE_LLVM "Support disassembly of jitted x86_64 code using LLVM" OFF)
+option(DYNARMIC_USE_PRECOMPILED_HEADERS "Use precompiled headers" ON)
option(DYNARMIC_WARNINGS_AS_ERRORS "Warnings as errors" ${MASTER_PROJECT})
if (NOT DEFINED DYNARMIC_FRONTENDS)
set(DYNARMIC_FRONTENDS "A32;A64" CACHE STRING "Selects which frontends to enable")