aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGPUCode <[email protected]>2022-08-15 21:00:14 +0300
committermerry <[email protected]>2022-08-15 21:00:01 +0100
commita62dc19605cf43d0c5989a4dfe98ca5c82f33b77 (patch)
tree3295d6649bf4a236b8ac7929d433ae281eeb1384 /CMakeLists.txt
parent3cb939e70b7ec29f789cbd0ed7547196507c81db (diff)
downloaddynarmic-a62dc19605cf43d0c5989a4dfe98ca5c82f33b77.tar.gz
dynarmic-a62dc19605cf43d0c5989a4dfe98ca5c82f33b77.zip
cmake: Bump minimum required cmake version
Version 3.12 is the minimum that supports the value of 20 for CMAKE_CXX_STANDARD. Also remove /std:c++latest to get rid of compiler logspam
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7fbd9db7..88cb7a85 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.8)
+cmake_minimum_required(VERSION 3.12)
project(dynarmic LANGUAGES C CXX ASM VERSION 6.2.3)
# Determine if we're built as a subproject (using add_subdirectory)
@@ -45,7 +45,6 @@ list(APPEND CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/CMakeModules")
# Compiler flags
if (MSVC)
set(DYNARMIC_CXX_FLAGS
- /std:c++latest # CMAKE_CXX_STANDARD has no effect on MSVC until CMake 3.10.
/experimental:external
/external:W0
/external:anglebrackets