aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMerryMage <[email protected]>2018-01-09 18:41:22 +0000
committerMerryMage <[email protected]>2020-04-22 20:39:27 +0100
commitcde2d48eb95502647d592fd1602d5722db7e0481 (patch)
tree9407f693e87f9cde5c17b42eb3ed7ad7bd10cf8c /CMakeLists.txt
parentf61da0b5a9cbf1dfce7e370e5fbb600858d31cb9 (diff)
downloaddynarmic-cde2d48eb95502647d592fd1602d5722db7e0481.tar.gz
dynarmic-cde2d48eb95502647d592fd1602d5722db7e0481.zip
CMakeLists: CMAKE_CXX_STANDARD as no effect on MSVC until CMake 3.10
We add the /std:c++latest flag to DYNARMIC_CXX_FLAGS to fix this.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b9f4ce5..7b38ad37 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,6 +41,7 @@ list(APPEND CMAKE_MODULE_PATH "${PROJECT_SOURCE_DIR}/CMakeModules")
# Compiler flags
if (MSVC)
set(DYNARMIC_CXX_FLAGS
+ /std:c++latest # CMAKE_CXX_STANDARD as no effect on MSVC until CMake 3.10.
/W4
/w34263 # Non-virtual member function hides base class virtual function
/w44265 # Class has virtual functions, but destructor is not virtual