aboutsummaryrefslogtreecommitdiffhomepage
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMerry <[email protected]>2022-07-11 15:57:14 +0100
committerMerry <[email protected]>2022-07-11 16:06:54 +0100
commitcd85b7fdaac28be99173a9380c4120c5d299d1e8 (patch)
treed9c2c5a268010ef58498173d0f6710d4c9ecbf3d /tests/CMakeLists.txt
parent6243e5a90e159187d7c4084e11068f5a3e7b1283 (diff)
downloaddynarmic-cd85b7fdaac28be99173a9380c4120c5d299d1e8.tar.gz
dynarmic-cd85b7fdaac28be99173a9380c4120c5d299d1e8.zip
emit_x64: Fix bugs in fast dispatcher
* We failed to invalidate entries if there are no patches required for a location descriptor. * Bug in A64 hashing code (rbx instead of rbp). * Bug in A32 and A64 lookup code (inconsistent choice of key: PC vs IR::LocationDescriptor). * Test case added.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 3d0013e8..05380ab3 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -20,6 +20,8 @@ endif()
if ("A64" IN_LIST DYNARMIC_FRONTENDS)
target_sources(dynarmic_tests PRIVATE
A64/a64.cpp
+ A64/misaligned_page_table.cpp
+ A64/test_invalidation.cpp
A64/testenv.h
)
endif()
@@ -44,7 +46,6 @@ if (DYNARMIC_TESTS_USE_UNICORN)
if ("A64" IN_LIST DYNARMIC_FRONTENDS)
target_sources(dynarmic_tests PRIVATE
A64/fuzz_with_unicorn.cpp
- A64/misaligned_page_table.cpp
A64/verify_unicorn.cpp
unicorn_emu/a64_unicorn.cpp
unicorn_emu/a64_unicorn.h