aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandre Bouvier <[email protected]>2022-09-16 00:22:02 +0200
committerMatthew Gregan <[email protected]>2022-09-21 18:47:36 +1200
commit06aa271e5bca1a74692c8828ad8585dd9598e092 (patch)
tree72be3c27b456820bff0bcd727c6e94df10e67710 /CMakeLists.txt
parent4783607ecc09e9493677a9c4e3db95f78d87409a (diff)
downloadcubeb-06aa271e5bca1a74692c8828ad8585dd9598e092.tar.gz
cubeb-06aa271e5bca1a74692c8828ad8585dd9598e092.zip
cmake: fix install rules
* don't install cmake test binaries * fix variable names in Doxyfile.in * install doc files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9cfae64..7ae58d4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -371,6 +371,7 @@ if(DOXYGEN_FOUND)
${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/docs/Doxyfile
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/docs
COMMENT "Generating API documentation with Doxygen" VERBATIM)
+ install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/docs/html/ TYPE DOC)
endif()
if(BUILD_TESTS)
@@ -382,7 +383,6 @@ if(BUILD_TESTS)
target_link_libraries(test_${NAME} PRIVATE cubeb gtest_main)
add_test(${NAME} test_${NAME} --gtest_death_test_style=threadsafe)
add_sanitizers(test_${NAME})
- install(TARGETS test_${NAME})
endmacro(cubeb_add_test)
cubeb_add_test(sanity)
@@ -397,7 +397,6 @@ if(BUILD_TESTS)
target_link_libraries(test_resampler PRIVATE cubeb gtest_main speex)
add_test(resampler test_resampler)
add_sanitizers(test_resampler)
- install(TARGETS test_resampler)
cubeb_add_test(duplex)