aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthew Gregan <[email protected]>2019-07-02 13:48:36 +1200
committerMatthew Gregan <[email protected]>2019-07-02 13:48:36 +1200
commit0d1d9d84fb3e827615903a79d2411a49789f0de3 (patch)
tree4886c6938cf0e951dfdeec6f176db09fe78105a2 /CMakeLists.txt
parent98a1c8e61c78d4e3b8839352617a1e2432717a42 (diff)
downloadcubeb-0d1d9d84fb3e827615903a79d2411a49789f0de3.tar.gz
cubeb-0d1d9d84fb3e827615903a79d2411a49789f0de3.zip
Link pthread when building USE_PULSE.
This was working accidentally by picking up pthread via the common configuration including USE_ALSA.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 82ffc99..2c4e069 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -156,7 +156,7 @@ if(USE_PULSE)
target_sources(cubeb PRIVATE
src/cubeb_pulse.c)
target_compile_definitions(cubeb PRIVATE USE_PULSE)
- target_link_libraries(cubeb PRIVATE pulse)
+ target_link_libraries(cubeb PRIVATE pulse pthread)
if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
target_link_libraries(cubeb PRIVATE dl)
endif()