aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authornyorain <[email protected]>2020-10-10 22:51:46 +0200
committerPaul Adenot <[email protected]>2020-10-28 16:55:14 +0000
commit9183f2e654e6e58e534b87490eb646236ecb8df7 (patch)
tree942270aa83e6fcc0378a2c0b4a1e8f0e1edf3adc /CMakeLists.txt
parent9905226379329bf95ce6b761eceae46dfe429d9a (diff)
downloadcubeb-9183f2e654e6e58e534b87490eb646236ecb8df7.tar.gz
cubeb-9183f2e654e6e58e534b87490eb646236ecb8df7.zip
Move aaudio backend to C++ & enable low latency
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a64b9e1..f8813c2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -214,8 +214,20 @@ endif()
check_include_files(aaudio/AAudio.h USE_AAUDIO)
if(USE_AAUDIO)
target_sources(cubeb PRIVATE
- src/cubeb_aaudio.c)
+ src/cubeb_aaudio.cpp)
target_compile_definitions(cubeb PRIVATE USE_AAUDIO)
+
+ # set this definition to enable low latency mode. Possibly bad for battery
+ target_compile_definitions(cubeb PRIVATE CUBEB_AAUDIO_LOW_LATENCY)
+
+ # set this definition to enable power saving mode. Possibly resulting
+ # in high latency
+ # target_compile_definitions(cubeb PRIVATE CUBEB_AAUDIO_LOW_POWER_SAVING)
+
+ # set this mode to make the backend use an exclusive stream.
+ # will decrease latency.
+ # target_compile_definitions(cubeb PRIVATE CUBEB_AAUDIO_EXCLUSIVE_STREAM)
+
target_link_libraries(cubeb PRIVATE ${CMAKE_DL_LIBS})
endif()