aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Beich <[email protected]>2019-09-05 17:02:19 +0000
committerMatthew Gregan <[email protected]>2019-09-09 13:49:48 +1200
commita7ae0234e8a56693fcc8b5bfd991261a01628963 (patch)
tree78377f4ac1c03ef71854aa083f043739c7b8101e /CMakeLists.txt
parentedf8c13d00e235f5741f8b17c8b804fdb1e26d8f (diff)
downloadcubeb-a7ae0234e8a56693fcc8b5bfd991261a01628963.tar.gz
cubeb-a7ae0234e8a56693fcc8b5bfd991261a01628963.zip
alsa: don't depend on libasound by default
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9138500..68d2657 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -163,7 +163,7 @@ if(USE_ALSA)
target_sources(cubeb PRIVATE
src/cubeb_alsa.c)
target_compile_definitions(cubeb PRIVATE USE_ALSA)
- target_link_libraries(cubeb PRIVATE asound pthread)
+ target_link_libraries(cubeb PRIVATE pthread ${CMAKE_DL_LIBS})
endif()
check_include_files(jack/jack.h USE_JACK)