aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrea Pappacoda <[email protected]>2021-09-25 01:01:29 +0200
committerMatthew Gregan <[email protected]>2021-11-01 20:31:46 +1300
commitf132be2032d9464e0ddc44fa875fd8e3e5f45aa2 (patch)
tree9cbeeab423a3c4cc6b64553110875cf2df166d1f /CMakeLists.txt
parent72f959807d5723c77576e52b1c2b33c28b55f246 (diff)
downloadcubeb-f132be2032d9464e0ddc44fa875fd8e3e5f45aa2.tar.gz
cubeb-f132be2032d9464e0ddc44fa875fd8e3e5f45aa2.zip
build(cmake): add version and soversion to the built library
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b541bca..1408988 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -86,6 +86,10 @@ target_compile_definitions(cubeb PRIVATE OUTSIDE_SPEEX)
target_compile_definitions(cubeb PRIVATE FLOATING_POINT)
target_compile_definitions(cubeb PRIVATE EXPORT=)
target_compile_definitions(cubeb PRIVATE RANDOM_PREFIX=speex)
+set_target_properties(cubeb PROPERTIES
+ VERSION ${cubeb_VERSION}
+ SOVERSION ${cubeb_VERSION_MAJOR}
+)
add_sanitizers(cubeb)