aboutsummaryrefslogtreecommitdiffhomepage
path: root/libs/hbb_common/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'libs/hbb_common/Cargo.toml')
-rw-r--r--libs/hbb_common/Cargo.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/libs/hbb_common/Cargo.toml b/libs/hbb_common/Cargo.toml
new file mode 100644
index 0000000..bc31223
--- /dev/null
+++ b/libs/hbb_common/Cargo.toml
@@ -0,0 +1,48 @@
+[package]
+name = "hbb_common"
+version = "0.1.0"
+authors = ["open-trade <[email protected]>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+protobuf = "3.0.0-alpha.2"
+tokio = { version = "1.15", features = ["full"] }
+tokio-util = { version = "0.6", features = ["full"] }
+futures = "0.3"
+bytes = "1.1"
+log = "0.4"
+env_logger = "0.9"
+socket2 = { version = "0.3", features = ["reuseport"] }
+zstd = "0.9"
+quinn = {version = "0.8", optional = true }
+anyhow = "1.0"
+futures-util = "0.3"
+directories-next = "2.0"
+rand = "0.8"
+serde_derive = "1.0"
+serde = "1.0"
+lazy_static = "1.4"
+confy = { git = "https://github.com/open-trade/confy" }
+dirs-next = "2.0"
+filetime = "0.2"
+sodiumoxide = "0.2"
+regex = "1.4"
+tokio-socks = { git = "https://github.com/open-trade/tokio-socks" }
+
+[target.'cfg(not(any(target_os = "android", target_os = "ios")))'.dependencies]
+mac_address = "1.1"
+
+[features]
+quic = []
+
+[build-dependencies]
+protobuf-codegen-pure = "3.0.0-alpha.2"
+
+[target.'cfg(target_os = "windows")'.dependencies]
+winapi = { version = "0.3", features = ["winuser"] }
+
+[dev-dependencies]
+toml = "0.5"
+serde_json = "1.0"