aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorAyke van Laethem <[email protected]>2024-02-26 14:44:52 +0100
committerRon Evans <[email protected]>2024-03-24 13:04:47 +0100
commitd628e3e2cb6f767dc5367bc43fb14751a509404a (patch)
tree29ad39275551411968b0a87032ddb386367a386f /flake.nix
parentd97e4dbccf73b42819b1b0c0692490170e753212 (diff)
downloadtinygo-d628e3e2cb6f767dc5367bc43fb14751a509404a.tar.gz
tinygo-d628e3e2cb6f767dc5367bc43fb14751a509404a.zip
ci: don't add --recursive when updating submodules
It's not generally needed. It was added in https://github.com/tinygo-org/tinygo/pull/3958 to fix an issue with binaryen that has since been fixed in a different way, so we don't need the googletest dependency anymore.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index b98612d32..52bac72d1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -18,10 +18,10 @@
#
# But you'll need a bit more to make TinyGo actually able to compile code:
#
-# make llvm-source # fetch compiler-rt
-# git submodule update --init --recursive # fetch lots of other libraries and SVD files
-# make gen-device -j4 # build src/device/*/*.go files
-# make wasi-libc # build support for wasi/wasm
+# make llvm-source # fetch compiler-rt
+# git submodule update --init # fetch lots of other libraries and SVD files
+# make gen-device -j4 # build src/device/*/*.go files
+# make wasi-libc # build support for wasi/wasm
#
# With this, you should have an environment that can compile anything - except
# for the Xtensa architecture (ESP8266/ESP32) because support for that lives in