aboutsummaryrefslogtreecommitdiffhomepage
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAndrzej Janik <[email protected]>2024-12-02 00:29:57 +0100
committerGitHub <[email protected]>2024-12-02 00:29:57 +0100
commit7a6df9dcbf59edef371e7f63c16c64916ddb0c0b (patch)
tree7800524ba25d38c514f1c769c9c1b665542c5500 /Cargo.toml
parent870fed4bb69d919a10822032d65ec20f385df9d7 (diff)
downloadZLUDA-7a6df9dcbf59edef371e7f63c16c64916ddb0c0b.tar.gz
ZLUDA-7a6df9dcbf59edef371e7f63c16c64916ddb0c0b.zip
Fix host code and update to CUDA 12.4 (#299)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml51
1 files changed, 24 insertions, 27 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8a7467a..2e8edcd 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,27 +1,24 @@
-[workspace]
-
-resolver = "2"
-
-members = [
- "ext/hip_runtime-sys",
- "ext/amd_comgr-sys",
- "comgr",
- "cuda_base",
- "cuda_types",
- "detours-sys",
- "level_zero-sys",
- "level_zero",
- "spirv_tools-sys",
- "zluda",
- "zluda_dump",
- "zluda_lib",
- "zluda_inject",
- "zluda_redirect",
- "zluda_ml",
- "ptx",
- "ptx_parser",
- "ptx_parser_macros",
- "ptx_parser_macros_impl",
-]
-
-default-members = ["zluda_lib", "zluda_ml", "zluda_inject", "zluda_redirect"]
+[workspace]
+
+resolver = "2"
+
+members = [
+ "ext/hip_runtime-sys",
+ "ext/amd_comgr-sys",
+ "comgr",
+ "cuda_base",
+ "cuda_types",
+ "detours-sys",
+ "zluda",
+ "zluda_dump",
+ "zluda_inject",
+ "zluda_redirect",
+ "zluda_ml",
+ "ptx",
+ "ptx_parser",
+ "ptx_parser_macros",
+ "ptx_parser_macros_impl",
+ "zluda_bindgen",
+]
+
+default-members = ["zluda", "zluda_ml", "zluda_inject", "zluda_redirect"]