aboutsummaryrefslogtreecommitdiffhomepage
path: root/ptx/Cargo.toml
diff options
context:
space:
mode:
authorAndrzej Janik <[email protected]>2024-09-23 16:33:46 +0200
committerGitHub <[email protected]>2024-09-23 16:33:46 +0200
commitc92abba2bb884a4dba8ca5e3df4d46a30878f27e (patch)
tree89bab98e3071aedd12f755bfde8a7c7382138ed7 /ptx/Cargo.toml
parent46def3e7e09dbf4d3e7287a72bfecb73e6e429c5 (diff)
downloadZLUDA-c92abba2bb884a4dba8ca5e3df4d46a30878f27e.tar.gz
ZLUDA-c92abba2bb884a4dba8ca5e3df4d46a30878f27e.zip
Refactor compilation passes (#270)
The overarching goal is to refactor all passes so they are module-scoped and not function-scoped. Additionally, make improvements to the most egregiously buggy/unfit passes (so the code is ready for the next major features: linking, ftz handling) and continue adding more code to the LLVM backend
Diffstat (limited to 'ptx/Cargo.toml')
-rw-r--r--ptx/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/ptx/Cargo.toml b/ptx/Cargo.toml
index 2e2995f..e2c4ff8 100644
--- a/ptx/Cargo.toml
+++ b/ptx/Cargo.toml
@@ -17,6 +17,9 @@ thiserror = "1.0"
bit-vec = "0.6"
half ="1.6"
bitflags = "1.2"
+rustc-hash = "2.0.0"
+strum = "0.26"
+strum_macros = "0.26"
[dependencies.lalrpop-util]
version = "0.19.12"