aboutsummaryrefslogtreecommitdiffhomepage
path: root/zluda/Cargo.toml
diff options
context:
space:
mode:
authorAndrzej Janik <[email protected]>2021-02-27 20:55:19 +0100
committerAndrzej Janik <[email protected]>2024-02-11 20:45:51 +0100
commit1b9ba2b2333746c5e2b05a2bf24fa6ec3828dcdf (patch)
tree0b77ca4a41d4f232bd181e2bddc886475c608784 /zluda/Cargo.toml
parent60d2124a16a7a2a1a6be3707247afe82892a4163 (diff)
downloadZLUDA-3.tar.gz
ZLUDA-3.zip
Nobody expects the Red Teamv3
Too many changes to list, but broadly: * Remove Intel GPU support from the compiler * Add AMD GPU support to the compiler * Remove Intel GPU host code * Add AMD GPU host code * More device instructions. From 40 to 68 * More host functions. From 48 to 184 * Add proof of concept implementation of OptiX framework * Add minimal support of cuDNN, cuBLAS, cuSPARSE, cuFFT, NCCL, NVML * Improve ZLUDA launcher for Windows
Diffstat (limited to 'zluda/Cargo.toml')
-rw-r--r--zluda/Cargo.toml40
1 files changed, 36 insertions, 4 deletions
diff --git a/zluda/Cargo.toml b/zluda/Cargo.toml
index 6e0d077..448154a 100644
--- a/zluda/Cargo.toml
+++ b/zluda/Cargo.toml
@@ -8,13 +8,45 @@ edition = "2018"
name = "zluda"
[dependencies]
+comgr = { path = "../comgr" }
+cuda_base = { path = "../cuda_base" }
+cuda_types = { path = "../cuda_types" }
+hip_common = { path = "../hip_common" }
+hip_runtime-sys = { path = "../hip_runtime-sys" }
ptx = { path = "../ptx" }
-level_zero = { path = "../level_zero" }
-level_zero-sys = { path = "../level_zero-sys" }
+zluda_dark_api = { path = "../zluda_dark_api" }
lazy_static = "1.4"
num_enum = "0.4"
lz4-sys = "1.9"
+tempfile = "3"
+paste = "1.0"
+rustc-hash = "1.1"
+rusqlite = { version = "0.28.0", features = ["bundled"] }
+# blake3 1.4 requires rust 1.66
+blake3 = "=1.3.3"
+dirs = "4.0.0"
+# we don't need elf32, but goblin has a bug where elf64 does not build without elf32
+goblin = { version = "0.5.1", default-features = false, features = ["elf64", "elf32", "endian_fd"] }
+memchr = "2.5.0"
+memoffset = "0.8"
+static_assertions = "1.1.0"
+
+[target.'cfg(windows)'.dependencies]
+winapi = { version = "0.3", features = ["heapapi", "std"] }
[dev-dependencies]
-cuda-driver-sys = "0.3.0"
-paste = "1.0" \ No newline at end of file
+paste = "1.0"
+rand_chacha = "0.3.1"
+rand = "0.8.5"
+num-traits = "0.2.14"
+half = { version ="1.8.2", features = ["num-traits"] }
+gag = "1.0.0"
+
+[target.'cfg(not(windows))'.dev-dependencies]
+libc = "0.2"
+
+[build-dependencies]
+vergen = { version = "7.5.1", default-features = false, features = ["git"] }
+# We don't use time crate, but this coerces vergen to not use newer version that requires
+# higher minimum rust version
+time = "=0.3.23" \ No newline at end of file