aboutsummaryrefslogtreecommitdiffhomepage
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorcomex <[email protected]>2023-07-01 15:02:25 -0700
committercomex <[email protected]>2023-07-01 17:27:35 -0700
commit0e191c271125321589dfdbb09731413550710c9a (patch)
treee0d9e826197d2fd66cc9b7fd8d11cc8c7fd6e3ac /CMakeLists.txt
parent98685d48e3cb9f25f6919f004ec62cadf33afad2 (diff)
downloadyuzu-android-0e191c271125321589dfdbb09731413550710c9a.tar.gz
yuzu-android-0e191c271125321589dfdbb09731413550710c9a.zip
Updates:
- Address PR feedback. - Add SecureTransport backend for macOS.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7e74733d6..14a9d85e3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,8 +64,9 @@ option(YUZU_DOWNLOAD_TIME_ZONE_DATA "Always download time zone binaries" OFF)
CMAKE_DEPENDENT_OPTION(YUZU_USE_FASTER_LD "Check if a faster linker is available" ON "NOT WIN32" OFF)
set(DEFAULT_ENABLE_OPENSSL ON)
-if (ANDROID OR WIN32)
+if (ANDROID OR WIN32 OR APPLE)
# - Windows defaults to the Schannel backend.
+ # - macOS defaults to the SecureTransport backend.
# - Android currently has no SSL backend as the NDK doesn't include any SSL
# library; a proper 'native' backend would have to go through Java.
# But you can force builds for those platforms to use OpenSSL if you have